FMS T-28 Trojan V4 Yellow 1400mm – Cursed?

A club member recently picked up the FMS 1400mm T28 as a step toward getting back in the air.  He’d been ill and hadn’t flown much for most of a year but he has flown a bit of everything and now does mostly Turbines so he wanted a war bird with retracts and flaps… something to get his fingers re-awakened but still with the extra “complications” of flaps and retracts so he wouldn’t get out of the habit of using those!  After a bit of debate he went for this bird:

I never did hear the whole story but apparently, right out of the box the plane had issues.  I heard stories of at least one speed controller swap, retract issues and a bad aileron servo…  I don’t know exactly the list or the sequence of events but he quickly ran out of patience to troubleshoot all the issues and offered to sell the bird at a bargain basement price. 

A second club member (let’s call him Gary) picked it up and got a warranty swap on the bad aileron servo which he replaced.  He planned to bring the plane to my shop to troubleshoot any other issues he found but as fate would have it, he was in the midst of one of his infamous multi-part swap/purchases and the plane one again changed hands, landing now with Steve.  One part of the plan didn’t change and that was to get it to my shop for a thorough once over.

Once the plane arrived Steve and I started testing and going over the plane to see what all was or wasn’t working.  We did a quick bind and testing of the plane and quickly found one issue… NONE of the three retractable retracts actually did anything!  Not a buzz, beep, wiggle or shake to be seen!  No amount of coaxing, servo reversing, battery swap, rebinding, driving with a servo tester or anything else would make them budge. 

Over the course of a few days I traced down all the wiring to each retract and nothing would convince any of them to move!  This is not as simple as it sounds as the receiver drives a distribution board in the body of the plane which then is wired via a multi-wire connector (looks like a balance connector on a 5S lipo) to another distribution circuit board/box buried in the wing root where the retracts, flaps, ailerons and lights for each wing are plugged in.  This is all starts to quickly look like a spaghetti bowl but eventually I pretty much had it mapped out in my mind.

Eventually I plugged in a servo at the wing root connection and proved that signals were getting to that point as the servo moved appropriately.  I did this for all three retracts and every one of them tested the same… bad retracts!  Now I have no idea how the retracts got to this point.  I’m fairly sure they are not shipped in the down position and all were now in that position.  They did not stink or have obvious damage so it was not obvious if they were somehow abused but it seems crazy that all 3 would fail in this manner.  I guess we will never know.

Fast forward a week or so and 2 of the 3 needed retracts have arrived at the shop.  Swapping them out is not overly difficult.  I found the simplest way was actually to completely open up the retract housing (split it after removing the 4 plate screws AND the 6 small diameter screws that hold the two sides together and just replace the whole trunion, strut and wheel assembly. 

Seemed easier than fiddling with all the set screws etc… especially for the nose gear with its’ C clip.  As best I can tell the electrical parts are all the same for nose and mains so I swapped out the Port main and then the nose gear and both worked perfectly after that!  So, confirmation that they were indeed bad.

Two or three weeks later another couple retracts came in and I once again dug into the T28.  Third retract install complete and it is working… Reassemble everything and then suddenly it doesn’t!!    Double check all connections and no go… time to take the plane apart again and recheck all those connections.  Re-seat all the connections and everything works fine again. 

OK, so back together and checking everything and what’s this… both Ailerons move in the same direction??  Long story short (this story is long enough) the servo that was supplied as a warranty replacement turns out to be a reversed servo!  So call the local hobby store and order a replacement (correct) servo… wait and then take it apart again and swap that servo out.  Now it should all be good, right?

Reassemble, checking at each step, and all looks good with the new servo functioning correctly until after the final wing assembly.  Plug the battery back in to do a final check and what the what??  When the battery is plugged in nothing happens… and I mean nothing!  No lights, no beeps, nothing!!  Try different batteries… nothing.  This is an ARF… when will we get to the ALMOST part of this??

At this point my cursing skills are well exercised and I’m beginning to think I might go pro…  Something with the new servo??  One more time to check all the wiring… disassemble the whole plane again and trace wires when I notice something.  One of the “wing root” connection boards looks like this:

Bare wires seem bad… especially when some of those little hair thin wires look like they might be touching?!  I have no idea but my theory now is this is what started all the issues… It’s possible that these wires were pulled out as repairs were done… by me, perhaps… by the other 2 guys that have had their hands in the plane… maybe.  But to my eye the insulation on the wires seem to have none of the white “goo” on them and a couple of the stray wires do.  I think this was something the factory missed on.  I’ll never be sure.

So while I have the plane plugged together BUT still all connected, I unplug the white XH style connector that feeds this side of the wing and try again and…  Beeps, buzzes and all the other “correct” noises issue forth!!  I think I may have heard some angels singing… just sayin…

So under a magnifying glass I went through and separated all the wires and painted that connection point with liquid masking tape.  Once finished the final product looked passable:

Once reassembled it all looked great.  Flaps, ailerons, rudder, throttle… check.  Retracts… all three down and locked and back up again… check.  This thing might just fly yet!  Just as I was doing the happy dance… Hey, why is that landing light not on…  At that point I had to make a decision… smash this thing into a hundred pieces and make up a good story for Steve on what unfortunate event had claimed the ill fated T28 or one more time time through the wiring.  OK, so this one was simpler.  About a 90% chance that the 2 wire, unkeyed connector (OK, its color coded but why not use a standard servo connector so idiots like me have a better chance to get it right?)  is plugged in backward.  Yep, that did it.

After all that, she looks to be ready to fly… finally.  After purchasing the plane at less than half of what it originally cost, Steve has spent enough on retracts and a servo that he is pretty much up to having paid full retail and then a bit!  If I charged minimum wage, I think he’d have to tell the wife “Sorry honey, no Christmas this year”!  Good thing we do this for fun.

Hopefully all this will be worth it when this bird take to the air.  T28s are typically great flyers so we are looking forward to seeing it in the air.  Maybe we should schedule an exorcism instead of a christening!

Leave a Reply

Your email address will not be published. Required fields are marked *